bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cvs [commit aborted]: out of memory;


From: Muraleedhara Reddy
Subject: Re: cvs [commit aborted]: out of memory;
Date: Wed, 16 Jul 2008 15:34:31 +0530

Hi Larry,

Thanks for your reply.

In our last try, we have copied the file directly to the CVS server to a
users home location and tried to check-in the file locally. We are able to
check-in the file to one test repository but unable to check-in to the
original one on the same CVS server. We got struck at this trial and ran out
of ideas.

FYI, so far we have tried changing default tmp directory (using cvs -T),
cleaning up /tmp on server (930 MB is there) and killing any hung up CVS
processes. But nothing worked.

As you said the disk space is no more issue. And no more CVS process/OS
issue (as we are able to check-in a test archive on the same server). So it
seems some issue with repository setup.

Would you give me any more ideas on this?

Thanks,
Muraleedhara.

===============================================================
On Tue, Jul 15, 2008 at 8:26 PM, Larry Jones <address@hidden>
wrote:

> Muraleedhara Reddy writes:
> >
> > cvs [commit aborted]: out of memory; can not allocate 225281184 bytes
>
> Here's what the manual says about that error:
>
>        There is insufficient (virtual) memory available to continue.
>        In client/server mode, the problem is almost certainly on the
>        server rather than the client; see Server requirements for
>        memory estimates.  Many systems have limits on the amount of
>        virtual memory that a single process can use, so a process can
>        run out of virtual memory long before the system itself has run
>        out.  The method of increasing the per-process limits varies
>        depending on the operating system.
>
> Note that the problem is memory, not disk space.
> --
> Larry Jones
>
> This game lends itself to certain abuses. -- Calvin
>


reply via email to

[Prev in Thread] Current Thread [Next in Thread]