bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Enabling PAM Authentication for CVS in AIX 5.2


From: Abdul Latif, PH.D.
Subject: Enabling PAM Authentication for CVS in AIX 5.2
Date: Thu, 16 Mar 2006 14:40:15 -0800 (PST)
User-agent: SquirrelMail/1.4.4

Hi,
I'm very sorry for the intrusion, but I hope you can help me or point me
to the right direction.

I am having some difficulties making the PAM-authentication work for CVS
login. I'm running the cvs login command as follows:
----------------------------------------------------
/opt/cvs-1.12.13/bin/cvs -d :pserver:address@hidden:/usr/cvsroot login
And getting the following error:

cvs login: authorization failed: server 10.22.21.81 rejected access to
/usr/cvsroot for user hat0464

DETAILS

I have built CVS from source using the 1.12.13 distribution with these
three flags:
--enable-pam --with-hardcoded-pam-service-name=pam --prefix=/opt/cvs-1.12.13

My inetd.conf entry is:
-----------------------
cvspserver      stream tcp nowait root /opt/cvs-1.12.13/bin/cvs cvs -f
--allow-root=/usr/cvsroot pserver

My services entry is:
----------------------
cvspserver      2401/tcp                        # CVS pserver authentication

My /etc/pam.d/cvs entry is:
----------------------------
auth    required        /opt/vas/lib/security/pam-vas.so
account required        /opt/vas/lib/security/pam-vas.so
session required        /opt/vas/lib/security/pam-vas.so

I have also tried it with /etc/pam.conf with these entries:
-----------------------------------------------------------
cvs     auth    required        /opt/vas/lib/security/pam-vas.so
cvs     account required        /opt/vas/lib/security/pam-vas.so
cvs     session required        /opt/vas/lib/security/pam-vas.so
These pam modules are supplied by the vintela software.

As far as I can tell, the PAM-authentication is not being activated and
I'm not sure what else to do. FYI, I do not have a $CVSROOT/CVSROOT/passwd
file and don't want to have one, because the pam module is supposed to do
the auhtentication using an AD LDAP server.

I'll very much appreciate any help you can provide or if you could point
me to someone who could.

Thanks.
Latif
______________________________________________
Abdul Latif, PH.D.
Sun Certified Enterprise Architect for the J2EE Platform
Sun Certified Java Developer
IBM Certified WebSphere Specialist

System Architects, Inc.
address@hidden
Direct: 770-330-2026
Fax: 404-948-1511
http://www.systemarchitectsinc.com





reply via email to

[Prev in Thread] Current Thread [Next in Thread]