bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Report : the CVS configure warning message => compat.h attached


From: Derek Price
Subject: Re: Report : the CVS configure warning message => compat.h attached
Date: Fri, 09 Dec 2005 11:10:16 -0500
User-agent: Mozilla Thunderbird 1.0.7 (Windows/20050923)

address@hidden wrote:

address@hidden wrote:

This appears to be the problem:

cc: Error: /usr/include/gssapi/compat.h, line 293: Missing ";". (nosemi)
       error: the system type is undefined
-------------^

Could you either figure out when header needs to be included on your
system for the "failed program" at the end of this message to compile
correctly?  If you can't look at line 293 of your
/usr/include/gssapi/compat.h and figure out which structure or type
remains undefined, please send me a copy and I will try and guess. Either way, I will need you to test whatever new program we come up with.

Thanks,

Derek


Glancing at the <gssapi/compat.h> you sent, it expects _AIX, __aix, __digital, __hpux, __irix, __linux, __mvs, __mvscics, __sunos, __solaris, _WINDOWS, _WIN32, or WIN32 to be defined.

Googling, the Compaq C compiler for your Tru64 UNIX defines:

Operating system name:  unix
                       __unix__
                       __osf
                       SYSTYPE_BSD
                       _SYSTYPE_BSD
Architecture name:      __alpha
Product name:           __DECC
                       __DECC_VER
                       LANGUAGE_C
                       __LANGUAGE_C__

So, the GSSAPI library you have installed was not built for your operating system. You need to replace it with one that works with Tru64.

Regards,

Derek

--
Derek R. Price
CVS Solutions Architect
Ximbiot <http://ximbiot.com>
v: +1 717.579.6168
f: +1 717.234.3125
<address@hidden>





reply via email to

[Prev in Thread] Current Thread [Next in Thread]