bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

More Info: CVS Import Bug - Please Respond


From: Oproescu Bogdan (KTXA 3)
Subject: More Info: CVS Import Bug - Please Respond
Date: Wed, 10 Aug 2005 10:19:23 +0200


   Hi Jim and all, 

   Thanks for your message below. My replies follow: 

   1. Yes, only .jar files cause the problem. The only pattern 
   that I see with the ones that cause this problem is that 
   they are quite large .jar files, and my guess is that there 
   is time overlap between the 2 parallel cvs import's and this 
   is what causes them to get corrupted. 

   2. Our CVS Server Version is 1.11.19, and this is installed in 
   a CVS Package on our CVS Central Server. We will not install 
   a new CVS Server Version until we are sure that it fixes the
   import-import and import-tag bugs that I described below. 

   3. The problem .jar files indicate 'kb' upon using 'cvs status', 
   so this is not the cause. 

   Please consider this issue further as it is very urgent for us. 

   Thanks and Cheers, Bogdan 

   Bogdan Oproescu   

   CREDIT SUISSE FINANCIAL SERVICES
   Technology & Services
   Advanced Middleware &
   Development Environments KTXA 3 
   Postfach 600
   CH-8070 Z├╝rich
   Tel.: +41 1 334 6846
   Fax.:+41 1 332 8024
   E-Mail: address@hidden
   Internet: http://www.credit-suisse.ch/de/index.html

-----Original Message-----
From: Jim Hyslop [mailto:address@hidden 
Sent: Tuesday, August 09, 2005 1:51 PM
To: Oproescu Bogdan (KTXA 3)
Cc: 'address@hidden'; 'address@hidden'
Subject: Re: More Info: CVS Import Bug - Please Respond

Oproescu Bogdan (KTXA 3) wrote:
>    Thanks for your message below. Here are the answers to your questions: 
> 
>    1. It is not only FNDB_T.jar that causes problems, there are also other 
>    jar files in the repository /rep/fnagl that recreate the same errors 
> below. 

Is it only .jar files that cause the problem? I note from your previous 
message that some jar files get imported OK, while others don't. Can you 
see any pattern to the ones that cause a problem? I'm assuming, by the 
way, that the messages you posted earlier were an extract from a much 
larger log.

>    2. I have reproduced these errors with CVS Clients 1.11.19 and 1.11.17 
>    and CVS Server 1.11.19, as shown below: 
> C:\Temp>cvs version
> Client: Concurrent Versions System (CVS) 1.11.19 (client)
> Server: Concurrent Versions System (CVS) 1.11.19 (client/server)

Hmmm... well, it's a long shot (the NEWS file doesn't mention any bug 
fixes similar to your problem) but version 1.11.20 is available.

>    3. We did tag the .jar files as binary in the $CVSROOT/CVSROOT/cvswrappers 
>    file as shown below: 

OK, so it doesn't appear to be a problem with the binary flag. Unless... 
can you double-check the status of the binary flags on the problem files 
using 'cvs status'? They should all indicate 'kb'

I'll be unable to check emails for the rest of the week. Hopefully 
someone else can step in and pick up trying to figure this out. (If 
anyone else cares to step in and offer suggestions, please feel free to 
do so :=)

-- 
Jim




reply via email to

[Prev in Thread] Current Thread [Next in Thread]