[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 'Dying gasps received from client.' with CVS 1.12.11

From: Jörg Bullmann
Subject: Re: 'Dying gasps received from client.' with CVS 1.12.11
Date: Sun, 13 Feb 2005 23:08:16 +0100

Hi Derek,

I think I just checked in a fix for the zlib issue. For some reason, compress_buffer_input() was returning EOF to its caller as soon as it hit Z_STREAM_END, even though there was data waiting to be returned to the caller. It solves the issue with the sample client input Joerg sent some time ago.

If you could both grab the CVS from CVS and let me know that I solved the problem correctly, I'll roll a 1.12.12 release soon.

I just checked out CVS, compiled it and --version says:

Concurrent Versions System (CVS) (client/server)

Copyright (C) 2005 Free Software Foundation, Inc.

Senior active maintainers include Larry Jones, Derek R. Price,
and Mark D. Baushke. Please see the AUTHORS and README files from the CVS
distribution kit for a complete list of contributors and copyrights.

CVS may be copied only under the terms of the GNU General Public License,
a copy of which can be found with the CVS distribution kit.

Specify the --help option for further information about CVS

With this I imported two test modules using MacCVSClient,
zlib data stream compression level 3. I use a MacCVSClient
beta because the current 1.9 cannot cope with truncated paths
in server responses. However, this beta uses the standard
Mac OS X zlib as all previous versions did. So no change there.

Both imports worked fine with I double checked
them against a 1.12.10 CVS where they both failed and caused
MacCVSClient to wait and wait and wait...

So, I'd say you nailed it! Good detective work. ;-) And
sorry for the delay in testing this.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]