bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Memory error when using user variables in loginfo


From: Jeremy Bopp
Subject: Memory error when using user variables in loginfo
Date: Wed, 8 Dec 2004 17:34:48 -0600

Hello, all.  I'm new to the list, so I hope this is the proper forum.

My company has a tool that makes use of a large number of user variables
in the hook files, and we seem to have tickled a bug.  You can pretty
reliably recreate the problem by referencing user variables in some
loginfo hooks.  Set and reference 6 variables with about 8 to 12
characters in each name and values that range in length from 5 to 10
characters.  Then commit some code that will trigger the loginfo entry.
You should see some error messages saying that some user variable could
not be located.  That variable may have some of one of your variable
names in it along with some garbage.

Attached is a patch that fixes the handling of a memory pointer that is
never updated after the array it points into is reallocated.  This
should apply cleanly to a 1.12.10 source tree using patch -p1 when
inside the tree.  My tests after using the patch indicated that the bug
was fixed, and I didn't notice any new ones crop up.

If a different patch format is required or if there are questions,
please contact me.

-Jeremy

------------------
Jeremy Bopp
Software Developer
Motive Inc.
address@hidden
------------------ 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]