bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Assumption added between 1.11.9 and 1.11.16 ?


From: Adrian Pepper
Subject: Assumption added between 1.11.9 and 1.11.16 ?
Date: Fri, 3 Sep 2004 11:34:37 -0400 (EDT)

>From a course instructor:

| There was a change made to CVS part way through last semester, and after
| that it seemed as if to check something out of a CVS repository the entire
| path down to the CVS repository must be visible.
|
| It doesn't seem right that a group member would have to make their root
| directory group readable for others to access the repository, but so far
| this is the only way I have been able to get checkout to work.
|
| The error is
|
| rees ~: cvs co nachos
| cvs [checkout aborted]: cannot getwd in /u/XXXXXXXXX/.newcvsroot/cvsroot:
| Permission denied


Because of security warnings, I upgraded from 1.11.9 to 1.11.16

Why it took so long for someone to report the above, I don't know.
(They've been working around as indicated all term).

We encourage users to use 711 on their home directories, which does
prevent getwd by others in sub-directories.  See comments above.


Adrian Pepper
Computer Science Computing Facility
University of Waterloo, Waterloo, Ontario, Canada
address@hidden




reply via email to

[Prev in Thread] Current Thread [Next in Thread]