[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS Diff Problem

From: Prashant
Subject: CVS Diff Problem
Date: 28 Jul 2004 12:07:55 -0700

Hi i'm having a problem with CVS that I think should be pretty
straightforward.  I have a local copy of a file, say file.c version  Someone else also has a copy somewhere else, makes a change
and commits it as 1.2.  Now when I go back to my local copy and do a
cvs diff, it shows nothing.  When I do a cvs status, it says "Needs
Patch".  Am I understanding the function of cvs diff incorrectly? Here
is a simple test:

file: test.c

//this is a test

cvs import -m "Test" test vendor start

cvs checkout test
cvs checkout -d test2 test
cd test

change test.c to say

//test.c has been modified

cvs commit -m "" test.c

cd ../test2
cvs diff

this produces no output. 
I've tried this on cvs versions 1.11.6, and 1.12.9.  Both produce the
same result.

Any suggestions?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]