bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: pserver login fails on 9 char passwords


From: Brian Murphy
Subject: Re: pserver login fails on 9 char passwords
Date: Mon, 29 Mar 2004 12:46:22 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031107 Debian/1.5-3

Mäkeläinen Juha wrote:

Resending a lost bug report:

-----Original-----
Sender: Mäkeläinen Juha Sent: 15 Jan 2004 14:04
Reciever: 'address@hidden'
Subject: pserver login fails on 9 char passwords


This problem was found when using cvs-1.11.11 server on HP-UX and wincvs client.
If user password is 9 chars long, the crypted password from client is 13 
characters but password got from HP-UX secure password system is 24 characters. 
The server.c module can not handle that.

Login fails and wincvs client says:

cvs -d :pserver:address@hidden:/cvs/fdits login Logging in to :pserver:address@hidden:2401:/cvs/fdits
cvs [login aborted]: authorization failed: server our-host.fi rejected access 
to /cvs/fdits for user u123456

Server (HP-UX B.11.11 U 9000/800) syslog.log message:

Jan 13 09:54:54 our-host syslog: login failure (for /cvs/fdits) Jan 13 09:56:16 
our-host syslog: password mismatch for u543251: F0sPYT3vo0Gmc vs. 
F0sPYT3vo0GmcT.Z51tttO6Q


I have used pre-compiled versions like cvs-1.11.8 and also compiled my own 
cvs-1.11.11 using these options:

CFLAGS="-g +DAportable -DLOG_AUTHPRIV" ./configure \
                --without-gssapi --enable-server-flow-control

(In this system HAVE_GETSPNAM is defined.)


Have you tried using the PAM in the 1.12 versions?

/Brian





reply via email to

[Prev in Thread] Current Thread [Next in Thread]