bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Assert in recurse.c when 'checkout -p' used


From: Doug carr
Subject: Re: Assert in recurse.c when 'checkout -p' used
Date: Mon, 22 Dec 2003 12:00:22 -0700


Hi Larry,

     Thanks for the speedy response.  Do you know if this is the type of thing
that would get changed in the near future?  Just trying to decide if it is
worthwhile to change my scripts and upgrade to 1.11.10 (with the danger being
that that message will change when the assert is fixed, requiring another script
change), or be patient and wait for a patch so I don't have to change my scripts
(assuming the error message is changed back to 'no such tag X')...

Thanks,
Doug.





address@hidden (Larry Jones) on 22/12/2003 10:39:03 AM

To:   Doug Carr/BOW Software address@hidden
cc:   address@hidden

Subject:  Re: Assert in recurse.c when 'checkout -p' used




Doug carr writes:
>
>         cvs: recurse.c:638: do_recursion: Assertion `repository != ((void
*)0)'
> failed.
>         cvs [checkout aborted]: received abort signal
>
> when running
>
>             $ cvs -d /cvsroot_test/test_rep checkout -pr DAC tie
>
> where DAC is a non-existent tag.

This seems to be a side effect of Derek's initial symlink fixes; in
particular, the elimination of xgetwd() in do_recursion.

-Larry Jones

Isn't it sad how some people's grip on their lives is so precarious
that they'll embrace any preposterous delusion rather than face an
occasional bleak truth? -- Calvin








reply via email to

[Prev in Thread] Current Thread [Next in Thread]