bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "Protocol error" fix not in v1.11.x?


From: Mark D. Baushke
Subject: Re: "Protocol error" fix not in v1.11.x?
Date: Wed, 10 Dec 2003 12:47:55 -0800

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Steve McIntyre <address@hidden> writes:

> On Wed, Dec 10, 2003 at 09:42:57AM -0500, Jim.Hyslop wrote:
> >
> >The problem's intermittent, so it may be difficult to verify if the patch
> >works for sure. I've only seen it once since we upgraded our CVS system
> >(other users have occasionally reported it). I'm assuming the log entry for
> >1.289 correctly identifies the problem that the commit is addressing :-) In
> >any case, I'll run this past the other CVS admins here (I'm not the UNIX
> >sysadmin, so I won't be doing the patch myself).
> >
> >By the way, other than the error message that gets spit out, does anyone
> >know the effects of this error? Looking at server.c, I'm guessing that the
> >file CVS/Template does not get created when checking out or updating new
> >directories. Or is the problem more subtle?
> 
> We've been seeing it for a while intermittently, with no ill
> effects. The even most likely to trigger it here is immediately
> checking out a newly-created branch straight after creating it, if
> that helps.

Every little bit of information may be useful. I have committed a patch
for the Template problem, let us know if you see the problem after you
upgrade your cvs to cvs 1.11.11 (or apply the patch I gave to server.c).

        Thanks,
        -- Mark
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (FreeBSD)

iD4DBQE/14Z73x41pRYZE/gRAt+0AJd3ex22+4ijmnmkkF+4tTNZR4j2AJ9noawe
gUYTHCKdX2DbniHazzeIKQ==
=ibYz
-----END PGP SIGNATURE-----




reply via email to

[Prev in Thread] Current Thread [Next in Thread]