bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: "Protocol error" fix not in v1.11.x?


From: Jim.Hyslop
Subject: RE: "Protocol error" fix not in v1.11.x?
Date: Wed, 10 Dec 2003 09:42:57 -0500

Mark D. Baushke [mailto:address@hidden wrote:
> Jim.Hyslop <address@hidden> writes:
> 
> > We've been experiencing "Protocol error: uncounted data 
> discarded" errors.
> > It looks like this was fixed for the 1.12 branch in 
> server.c (CVS rev 1.289)
> > but has not been merged into the 1.11.x branch as a bug fix 
> (1.11 branched
> > at 1.284). If this is the case, could this fix please be 
> merged to the
> > branch for the next 1.11 rev?
> 
> If you are able to reproduce the problem, could you apply the patch to
> your cvs 1.11.10 sources and see if it fixes the prbolem?
Thanks for the patch, Mark.

The problem's intermittent, so it may be difficult to verify if the patch
works for sure. I've only seen it once since we upgraded our CVS system
(other users have occasionally reported it). I'm assuming the log entry for
1.289 correctly identifies the problem that the commit is addressing :-) In
any case, I'll run this past the other CVS admins here (I'm not the UNIX
sysadmin, so I won't be doing the patch myself).

By the way, other than the error message that gets spit out, does anyone
know the effects of this error? Looking at server.c, I'm guessing that the
file CVS/Template does not get created when checking out or updating new
directories. Or is the problem more subtle?

-- 
Jim Hyslop 
Senior Software Designer 
Leitch Technology International Inc. (<http://www.leitch.com/>) 
Columnist, C/C++ Users Journal (<http://www.cuj.com/experts>) 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]