bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: different CVS_SERVER for different hosts


From: Paul Edwards
Subject: Re: different CVS_SERVER for different hosts
Date: Sat, 01 Nov 2003 04:16:40 GMT

"Shaun Tancheff" <address@hidden> wrote in message news:address@hidden
> For one, cygwin *ships* a pre-built CVS.

This is no good to me.  I need to be able to put some printfs
in of my own to see why the windows executable is hanging.

> For two, don't bother trying until you have *at least* all of
> the development tools, including the typical gnu environment.

I don't know how much of it I installed at the time.

> For three, everything in cygwin is built out side the source
> tree:
>
> # tar xzvf cvs-1.11.x.tar.gz
> # mkdir cvs
> # cd cvs
> # ../cvs-1.11.x/configure

Under bash, this fails with "No such file or directory".

Last time I ran it with "sh ./configure", it mostly worked, but
locked my computer up on the dependfiles or something like
that.

I'll try it again now that I'm operating outside the install
directory.

> > When I realised the EMX directory existed, I tried using
> > that, by copying it into multiple directories (the
> > instructions were not correct), but that still didn't work,
> > complaining about fnmatch.h or something.
>
> Afaik the latest emx (1.11.2.x) was from the emx-new directory.

There is only an emx directory, there's no emx-new, shipped
in cvs 1.11.9.

> But like I said before I treated EMX synonmous with OS/2 so there
> is probably some OS/2 calls that need to be modified for DOS.
> If that works, making a 1.11.2 to 1.11.9 patch should be relativly
> trivial. (The 1.10.6 -> 1.11.2 was).

Ok, I'll try a few more things.

BFN.  Paul.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]