bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cvs 1.11.9 for windows hanging


From: Mark D. Baushke
Subject: Re: cvs 1.11.9 for windows hanging
Date: Tue, 28 Oct 2003 14:37:32 -0800

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi Paul,

The input and the output are exactly what I would expect for a correctly
functioning client/server exchange.

I wonder what version of cvs is being run by sourceforge.net these
days... it doesn't answer a 'cvs version' command for me.

This sounds something like the problem with cvs 1.11.2 fixed with this
patch:

2002-10-24  Derek Price  <address@hidden>

        * buffer.c (stdio_buffer_shutdown): Remove the getc() call used to
        detect spurious output from clients since getc() would sometimes
        block and hang indefinately if the client kept the conection open but
        sent no data.  Bug reports state that this hapened frequently with
        older clients connecting to 1.11.2 servers, especially when
        compression is enabled.
        (Original report from Mark D. Baushke.
         Original patch from Peter Wemm.)

  http://ccvs.cvshome.org/source/browse/ccvs/src/buffer.c.diff?r1=1.19&r2=1.20

Try using -z0 compression to see if that helps your situation or not.

        -- Mark
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (FreeBSD)

iD8DBQE/nu+s3x41pRYZE/gRAjKpAKDVUFMSYo+NFyeSqvPuLO7O1K9h6wCfUoPG
FDzpBElO6T/dTMVq3AeIVMA=
=Lj+J
-----END PGP SIGNATURE-----




reply via email to

[Prev in Thread] Current Thread [Next in Thread]