bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: linux client / NT server and misinterpreted $CVSROOT (ie address@hid


From: Harry Slaughter
Subject: Re: linux client / NT server and misinterpreted $CVSROOT (ie address@hidden:c:/cvs
Date: Wed, 30 Jul 2003 20:08:08 GMT
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

solution posted below:

Harry Slaughter wrote:
i have a proper pserver string in the format: ":pserver:address@hidden:c:/cvs"

i found one thread on this topic in another newsgroup and no other references (including cvs/bugzilla), but i can't imagine i'm the only one having this problem.

the trouble is that when you use that format for $CVSROOT under linux, cvs
misinterprets "c:" and you get errors:

address@hidden:~/cvs/rcp> setenv CVSROOT ":pserver:address@hidden:c:/cvs"

address@hidden:~/cvs/rcp> cvs login
cvs login: CVSROOT may only specify a positive, non-zero, integer port (not `c:').
cvs login: Perhaps you entered a relative pathname?
cvs [login aborted]: Bad CVSROOT: `:pserver:address@hidden:c:/cvs'.
Exit 1

address@hidden:~/cvs/rcp>

i read that this bug was introduced with 1.11 (it doesn't exist in 1.10)

i've tried building 1.10, but it won't build on my system (RH9). and i can't build the latest src RPMS from cvshome.org either (stupid new rpmbuild is a mess).

so i'm stuck with 1.11.* versions, and they all seem to have this same bug.

is there a workaround for it? i've tried putting '\' in front of various things.
that doesn't work either.

a nice usenet read emailed me the answer
instead of:
  :pserver:address@hidden:c:/cvs

use:
  :pserver:address@hidden:/c//cvs

nice hack eh?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]