bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS problems with revision numbers 0.* ?


From: Michele Zamparelli
Subject: Re: CVS problems with revision numbers 0.* ?
Date: Thu, 09 Jan 2003 15:14:39 +0100

Larry Jones wrote:

> CVS uses revision "0" as a special flag to indicate a newly-added file
> but it seems that some of the code incorrectly interprets any revision
> number starting with 0 the same way.  Legitimate revision numbers
> starting with 0 are quite rare, so it's never been a problem.  I've
> checked in some changes that I believe fix the problem -- you can get
> the current development version of CVS from www.cvshome.org and try it
> out if you like.
>
> -- Calvin

Hi Larry,

Thanks very much for your answer.

I will try out your changes and let you know.
If you have opened an official ticket for this issue I would love to have
the number.

I shamelessly exploit your kindness in answering to me by asking/reporting
one more "unxpected behaviour":
The Cederqvist manual on :

http://www.cvshome.org/docs/manual/cvs_3.html#SEC42

seems to suggest that the import command can be used to add empty
directories to the repository. This does not seem to be true and in the
example above, the directories man and testing are not created on the server.
Why is that ?

Thanks

M.


--

-----------------------------------------------------------------------------
Michele Zamparelli                         E-Mail: address@hidden
ESO - EUROPEAN SOUTHERN OBSERVATORY        Phone : +49 89 32006271
Karl Schwarzschild Strasse, 2              Fax   : +49 89 32006320
D-85748 Garching bei M√ľnchen - Germany
-----------------------------------------------------------------------------






reply via email to

[Prev in Thread] Current Thread [Next in Thread]