bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

(no subject)


From: O. Hartmann
Subject: (no subject)
Date: Tue, 15 Oct 2002 18:55:04 +0200 (CEST)

>Submitter-Id:   net
>Originator:     O. Hartmann
>Organization:   IPA University of Mainz (Physics of the Atmosphere)
net
>Confidential:  no
>Synopsis:      gcc 2.95.4 gcc/f77 bug in FBSD 4.7-RELEASE (Abort trap)
>Severity:      serious
>Priority:      high
>Category:      FreeBSD 4.7-RELEASE/gcc 2.95.4
>Class:         sw-bug
>Release:       1.11.1p1-FreeBSD
>Environment:
        
System: FreeBSD mail.physik.uni-mainz.de 4.7-RELEASE FreeBSD 4.7-RELEASE #3: 
Tue Oct 15 17:22:41 CEST 2002 address@hidden:/usr/obj/usr/src/sys/MAIL i386


>Description:
        Compiling numerical software with f77 from gcc-2.95.4/FreeBSD 
4.7-RELEASE results
        in a unusable binariy image causing immediately 'Abort trap' after 
call. Same problem
        occurs compiling this piece of standard f77 code with PGI pgf90 or 
pgf77 under
        Linuxulator, linux_base 7.1-1 as newly installed after installation of 
FreeBSD 4.7-R.
        
        Using native f77 and gdb shows an immediately abort of the binary image.

        Courios is the following observation: 30 minutes before the faulty 
behaviour,
        the compilation AND execution produces the expected results. After that 
        this error occurs.

        In the past we had the same problem with another small program which 
compiled and
        executed in the meanwhile. Before I was told to check what's wrong with 
the 
        reapetedly occurence of this strange behaviour I executed the binary 
from the
        same NFS location on another system - with success! 10 minutes later on 
the same
        system I got the same error (Abort trap). this behaviour is more than 
strange!
>How-To-Repeat:
        Can't be repeated, it seems to be weird what's going on. We couldn't 
reproduce
        the problem due to the fact that under exactly the same conditions both 
results
        were different.

        We tried the faulty binary on another system - with success (also 
FreeBSD 4.7,
        the same brand). After about 10 minutes, the same images showed up the 
same
        behaviour.

>Fix:
        Not known!




reply via email to

[Prev in Thread] Current Thread [Next in Thread]