[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Axiom-developer] Re: [build Axiom] updated Windows buildinstruction

From: Vanuxem Grégory
Subject: RE: [Axiom-developer] Re: [build Axiom] updated Windows buildinstructions
Date: Thu, 21 Sep 2006 00:14:48 +0200

Le mercredi 20 septembre 2006 à 16:57 -0400, Page, Bill a écrit :
> > and in the file src/scripts/document the latex variable is
> > defined differently: `which latex` in the tla repository and
> > latex in the darcs one.
> This is a change I made just last night while testing the windows
> build... I guess I might as well explain it here. :) It turns out
> that this is just a silly way to refer an executable file. It
> breaks if the path to the executable contains directory names
> with spaces - something that is quite frequent on Windows. The
> new version of MikTeX puts the 'latex.exe' file in the
> "c:/Program Files/MikTeX" directory and this causes a failure
> in the 'document' script. By just writing 'latex' instead of
> `which latex` we let the system lookup the executable in the
> normal manner.

OK, I understand now, I checked out axiom--windows--1 with darcs today
since it can be considered as the official branch for you. Personally, I
never install "Unix world" softwares (Axiom, Cygwin, MinGW, MikTeX,
Perl, Python etc...) in a path with spaces.

> > It's on my TODO list to update my Windows version (the
> > tla one) up to Gold patch-50
> What version of tla do you use on Windows? Does it work
> reliably for you? Have you tried to delete a tla archive from
> Windows yet? With the version of tla what I was using this
> is extremely awkward because very long file names prevent
> the usual method of deleteing directories from working.

No, I tried in the past without success. I've never tested darcs on
Windows. I thought that the official branch was on the tla repository
so I downloaded it from Linux.

> > but I first need to know why the bug #312 is specific to
> > Axiom on Linux (see
> >
> > 
> If you have patience, perhaps you could try a binary search
> through the older linux versions to find where the failure
> was introduced. The axiom--windows--1 branch was cloned from
> the linux version at about patch-30, I think. You can retrieve
> the older patch versions from the tla archive by appending the
> patch suffix to the archive name, like this:
>   $ tla get axiom--main--1-patch-50 axiom-50
>   $ tla get axiom--main--1-patch-49 axiom-49
>   ...

OK, thanks. I don't know how I will do. I diff-ed some weeks ago the
int/algebra/*.spad (between patch-(49 or 50) and the windows branch) and
tested individually each modified file without success. So it seems to
me that the bug was introduced in the interpreter or somewhere else but
not in the algebra files. I could be wrong though.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]