[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Axiom-developer] Error with Axiom.CVS & gcl-2.6.1

From: Wolfgang Zocher
Subject: [Axiom-developer] Error with Axiom.CVS & gcl-2.6.1
Date: 26 Oct 2003 13:58:32 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2

Hi all,

when I tried to build axiom from scratch last night I got the errors listed
below. Is this kind of error symptomatic for the new release of gcl? Has
anyone tried to compile with gcl-2.7.x (CVS)? 

Here is the interesting part of the log-file:

   compiling local solveBernoulli : (Record(coef1: F,coefn: F,exponent: 
NonNegativeInteger),BasicOperator,Symbol,F) -> Union(F,failed)
   Semantic Errors:
      [1]  ElementaryFunctionODESolver is not a known type

      [1] solve: not known that (OrderedSet) is of mode (CATEGORY package 
(SIGNATURE solve ((Union F failed) F F (BasicOperator) (Symbol))))
      [2] checkBernoulli: not known that (Ring) is of mode (CATEGORY package 
(SIGNATURE solve ((Union F failed) F F (BasicOperator) (Symbol))))

****** comp fails at level 4 with expression: ******
error in function solveBernoulli

(SEQ (LET |n1| (- 1 (|::| (|rec| |exponent|) (|Integer|))))
     (LET |deq|
       (+ (+ (|differentiate| |yx| |x|)
             (* (* |n1| (|rec| |coef1|)) |yx|))
          (* |n1| (|rec| |coefn|))))
     (LET |sol|
       (|::| | << | (|solve| |deq| |y| |x|) | >> |
             (|Record| (|:| |particular| F) (|:| |basis| (|List| F)))))
     (|exit| 1
             (/ (- (** |yx| |n1|) (|sol| |particular|))
                (|first| (|sol| |basis|)))))
****** level 4  ******
$x:= (solve deq y x)
$m:= $EmptyMode
((((|deq| #) (|n1| #) (|exponent| #) (|coefn| #) ...)))

   >> Apparent user error:
   no modemap for solve with 3 arguments

protected-symbol-warn called with (NIL)
(1) -> 0 making /home/wolzoc/axiom-athlon/mnt/linux/algebra/NODE1.o from 
cp: Aufruf von stat für 
»/home/wolzoc/axiom-athlon/int/algebra/NODE1.NRLIB/code.o« nicht möglich: Datei 
oder Verzeichnis nicht gefunden
make[3]: *** [/home/wolzoc/axiom-athlon/mnt/linux/algebra/NODE1.o] Fehler 1
make[3]: Leaving directory `/home/wolzoc/axiom-athlon/src/algebra'
make[2]: *** [algebradir] Fehler 2
make[2]: Leaving directory `/home/wolzoc/axiom-athlon/src'
make[1]: *** [srcdir] Fehler 2
make[1]: Leaving directory `/home/wolzoc/axiom-athlon'
make: *** [all] Fehler 2


reply via email to

[Prev in Thread] Current Thread [Next in Thread]