avrdude-dev
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avrdude-dev] [patch #7720] Bug in EEPROM write


From: Rene Liebscher
Subject: [avrdude-dev] [patch #7720] Bug in EEPROM write
Date: Mon, 06 Feb 2012 07:36:40 +0000
User-agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7

Follow-up Comment #2, patch #7720 (project avrdude):

If the interface of paged_load/write is outdated, so may be better retire them
and put some write/read_page function at their places.


  int  (*write_page)    (struct programmer_t * pgm, AVRPART * p, AVRMEM * m, 
                          unsigned int page_number, unsigned int n_bytes);
  int  (*read_page)     (struct programmer_t * pgm, AVRPART * p, AVRMEM * m,
                           unsigned int page_number, unsigned int n_bytes);


If you always write/read whole pages the n_bytes parameter can be discarded
too.

Main reason to change the names of the functions are the patches in the patch
tracker and and in other places at the web which would all fail to work if
using still the old interface (anybody really cares about the compiler
warnings?). The same problem we had already when paged_load/write changed
their interfaces. Using new names, people get at least a compiler error and
must fix this to be able to use paged functions again.


    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/patch/?7720>

_______________________________________________
  Nachricht geschickt von/durch Savannah
  http://savannah.nongnu.org/




reply via email to

[Prev in Thread] Current Thread [Next in Thread]