[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avrdude-dev] /dev/parport0 not recognized

From: Theodore A. Roth
Subject: Re: [avrdude-dev] /dev/parport0 not recognized
Date: Tue, 15 Jun 2004 15:46:49 -0700 (PDT)

On Wed, 16 Jun 2004 address@hidden wrote:

> I am running avrdude on Slackware 9.1 Linux with kernel 2.6.6.  I get the
> following response:
> ----------------------------------------------------------------------
> inx# avrdude -p m8 -c dt006
> avrdude: can't open device "/dev/parport0": No such device or address
> avrdude: failed to open parallel port "/dev/parport0"

Does /dev/parport0 exist?

Here's what is looks like on my debian system

  $ ls -l /dev/parport0
  crw-rw-rw-    1 root     root      99,   0 Oct 22  2002 /dev/parport0
  $ uname -a
  Linux knuth 2.6.6-1-686 #1 Wed May 12 14:57:57 EST 2004 i686 GNU/Linux

Do you have the parport module installed?

  $ lsmod | grep par
  parport_pc             35008  1
  parport                41832  2 lp,parport_pc

> ----------------------------------------------------------------------
> I am running as root and have no trouble programming an ATMega8 with
> ponyprog2000 for linux.  I get the same response with version 4.3.0 and the
> current cvs.

Does ponyprog use the parport driver or does it use direct IO access to
the parallel port? Does ponyprog work if you are not root? You really
should not need to be root to run avrdude.

> Trying /dev/lp0 yields the following:
> ----------------------------------------------------------------------
> inx# avrdude -P /dev/lp0 -p m8 -c dt006
> avrdude: can't claim device "/dev/lp0": Invalid argument
> ----------------------------------------------------------------------

I don't think that /dev/lp0 will work since we are not using direct IO
access with avrdude.

Ted Roth
PGP Key ID: 0x18F846E9
Jabber ID: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]