automake
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Option Consistency


From: Bruce Korb
Subject: Re: Option Consistency
Date: Tue, 30 Jul 2002 10:22:42 -0700

Eric Siegerman wrote:
> 
> On Tue, Jul 30, 2002 at 07:46:18AM -0700, Bruce Korb wrote:
> > [...] you still
> > need to have both [suffix and compressor-program name] be
> > specifiable so you are not boxed into
> > cutting a new release in order to support a combination
> > you didn't plan for.
> > >
> > >   for f in $DIST_FORMATS; do
> > >     eval suffix=\$${f}_SUFFIX
>    +    eval program=\$${f}_COMPRESSOR

> The example assumes that the compressor program is the same as
> the case regexp.  For full generality, the latter should be a
> generic name for the compression format

Yep.  Actually, the loop should simplify:

> > >   for f in $DIST_FORMATS; do
> > >     eval suffix=\$${f}_SUFFIX
> > >     [ -n "${suffix}" ] && suffix=.${suffix}
>    +    eval program=\$${f}_COMPRESSOR
> > >     tar cf - ${distdir} | ${program} > ${distdir}.tar${suffix}
> > >   done

unless someone actually does an "rpm" or "pkgadd" format :-)



reply via email to

[Prev in Thread] Current Thread [Next in Thread]