[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: AM_INCLUDE is a bad name.

From: Pavel Roskin
Subject: Re: AM_INCLUDE is a bad name.
Date: Mon, 5 Feb 2001 16:18:35 -0500 (EST)

Hello, Tom!

> Pavel> How about renaming AM_INCLUDE to AMINCLUDE everywhere? The
> Pavel> patch is attached. It fixes all tests.

My approach was too formal. AM_INCLUDE is a variable, but the names of
variables shouldn't contain any capital letters. My fault.

> What if instead we decide on a permanent naming scheme for automake
> internal variables?  Then we can start moving towards that over time,
> starting here.
> What if instead we use `_AM_'?  Or `_am_'?

I believe that names beginning with am_ are private. I.e. AM_INCLUDE
should become am_include. I believe that user code should not do anything
with the names beginning with ac_ and am_.

Public names don't have any specific prefix: cross_compiling, SHELL,
program_suffix, x_libraries, M4, MISSING etc. It's too late to introduce

Pavel Roskin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]