[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] AUCTeX doesn't run bibtex

From: Egon Kidmose
Subject: Re: [AUCTeX] AUCTeX doesn't run bibtex
Date: Fri, 10 Jul 2015 08:06:59 +0000

Spot on! - `C-c  C-n` (TeX-normal-mode)  fixed it :D
Thanks a lot!

Care to confirm if understand the issue correctly?
1) AUCTeX relies on the results of parsing the *.tex files for this to work.
2) In my case, the parsing was never done
3) `TeX-normal-mode` triggers the parsing and stores the result in ./auto
4) Restart emacs for unicorns and free candy everywhere!

Regarding 2: 
Fixed it by adding this to .emacs.d :
    (setq TeX-parse-self t) ; Enable parse on load.
    (setq TeX-auto-save t) ; Enable parse on save.
[ ]

Any idea if it's problem on my end (my config/another mode interfering)?
or is it the intended behavior that AUCTeX requires the above to be fully 

If this is indeed the intention then I'd would think that changing the default 
of `TeX-parse-self` and `TeX-auto-save` to true would be a good idea:
Things would work better out of the box, and those seeking performance 
improvement could actively disable them. 

Once again: Thank you both very much for the assistance!

Egon Kidmose
Industrial PhD Student
Wireless Communication Networks (WCN) Section,
Department of Electronic Systems, Aalborg University
Room A4-203, Fredrik Bajers Vej 7, 9220 Aalborg Oest
Phone +45 61 78 29 04 

> -----Original Message-----
> From: Mosè Giordano [mailto:address@hidden
> Sent: 9. juli 2015 20:13
> To: Egon Kidmose
> Cc: address@hidden; address@hidden
> Subject: Re: [AUCTeX] AUCTeX doesn't run bibtex
> 2015-07-09 13:17 GMT+02:00 Egon Kidmose <address@hidden>:
> >> In `TeX-command-query' AUCTeX does check if the bibliography file is
> >> newer than the .bbl file, and in my case AUCTeX suggests indeed to
> >> run BibTeX after editing the bibliography file.  Egon, what does
> >>
> >>     M-: (LaTeX-bibliography-list) RET
> >>
> >> return in paper.tex buffer for you?
> >
> > Prints 'nil' in the minibuffer
> This is a problem, you should get
>     (("IEEEabrv") ("bib/paper"))
> Do you have file parsing enabled?  Do you get the same answer also after 
> issuing C-c
> C-n in the paper.tex buffer?
> Bye,
> Mosè

reply via email to

[Prev in Thread] Current Thread [Next in Thread]