[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] Local Variable ignored - almost got it

From: NOGUET Dominique
Subject: Re: [AUCTeX] Local Variable ignored - almost got it
Date: Thu, 23 Aug 2012 14:31:16 +0000



Well having visual-line-mode alone, it says 'visual-line-mode void-function... 
so I guess I just do not have it :-(
This sounds a bit stupid, but I was not suspecting this could cause the local 
variable issue. Besides, I do not see this message when I switch on all the 
hooks... well actually I guess it's there, but just passing too fast... well, 
when I check the 'recent messages' buffer it is there indeed. I'll do this 
first in the future... promised.

Also, when visual-line-mode is the only hook, the buffer remains in Fundamental 
mode, which would have been a hint that something went wrong when opening the 
File. Except that when I use this hook in combination with (add-hook 
'LaTeX-mode-hook 'LaTeX-math-mode), the LaTeX/M mode is applied and it looks 
like the file was loaded properly. 

I wanted to install visual-line-mode, but could not find it for xemacs. Maybe I 
could use the one for emacs, but I would like to avoid other side effects which 
are always hard to track. Bottom line is, I'll probably live without it.

(If I may, I would suggest the Auctex manual to be a bit more cautious by 
warning users that suggested hooks are not all available in all 
distributions... I know, I should run it with emacs, not xemacs, but I'm sure 
I'm not the only one doing this.)

Thanks a lot again. 

Most of the time, problems look stupid... once you found the solution ;-)

-----Message d'origine-----
De : address@hidden [mailto:address@hidden De la part de Joost Kremers
Envoyé : jeudi 23 août 2012 15:37
À : address@hidden
Objet : Re: [AUCTeX] Local Variable ignored - almost got it

On Thu, Aug 23, 2012 at 12:56:27PM +0000, NOGUET Dominique wrote:
> Hi,
> I managed to get Local variables to work in non LaTeX file (e.g in a text 
> file)!
> Then I tried to make LaTeX mode to run 'lighter' by removing all the 
> hooks. => managed to get Local variables to work in .tex files too :-) Put 
> the hooks back one by one to find the nasty one. And my conclusion is : 
> (add-hook 'LaTeX-mode-hook 'visual-line-mode) was guilty.

mmm... i define a function in my .emacs that contains a few customisations for 
auctex and which i add to LaTeX-mode-hook:

(defun jk-LaTeX-mode-hook-function ()
  "Function to add to LaTeX-mode-hook."
  (TeX-fold-mode 1)
  (local-set-key "\C-cb" 'ebib-insert-bibtex-key)
  (local-set-key "\C-cs" 'ebib-entry-summary)
  (local-set-key "\M-[" 'TeX-insert-braces)
  (local-set-key [C-return] 'TeX-fold-paragraph)
  (visual-line-mode t)
  (adaptive-wrap-prefix-mode t))

as you can see, i also turn on visual-line-mode, but i have no problem with 
local variables...

have you tried activating visual-line-mode *without* any of the other hooks? 
perhaps there's some interaction involving not just visual-line-mode...


Joost Kremers
Life has its moments

auctex mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]