[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] Install report: XEmacs and Windows XP

From: David Kastrup
Subject: Re: [AUCTeX] Install report: XEmacs and Windows XP
Date: Tue, 17 May 2005 23:50:43 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

Michael Forster <address@hidden> writes:

> I always wanted to try out preview-latex and having read the recent
> discussion about the release, I thought, some testing by an
> unexperienced (in terms of installing AUCTeX) user on XEmacs/Windows
> could help you to improve the XEmacs support and also the install
> documentation.
> Please note, that the following is not meant as a rant, but rather
> as a guide, where the install story could be improved. I am sure
> that most other Windows users would have given up much earlier.

This is very much appreciated.

> ======================================================================
> I did the following, starting on 2005-05-16 10:15 (+10:00):
> 1) O.k., so I thought, I'd start with a freshly installed XEmacs,
>    without the risk of something being screwed up. So I moved away my
>    ~/.xemacs directory and downloaded the newest XEmacs (21.4.13)
>    using the net installer
> and native install. XEmacs/Windows currently comes with AUCTeX 1.46,
> so I deselected that. No problems. MikTeX is not reinstalled.
> 2) Check out AUCTeX from CVS using TortoiseCVS. No problems.
> 3) Where's the install documentation? README.CVS: run Ok,
>    Standard. What else? RELEASE? No install documentation. Ah!,
>    doc/install.texi and doc/wininstall.texi.

Uh, running ./ should have given you INSTALL and README.
And the very first paragraph of README.CVS says:

    If you retrieved AUCTeX via CVS instead of as a regular release,
    there are some files that need to be generated from their
    respective source files before you can continue reasonably with
    the instructions detailed in the README and INSTALL files (which
    will not be present otherwise).

Ok, so you missed that.  Do you have a suggestion how we could write
this in a manner that people will _not_ miss it?  I am not trying to
blame you: there is no sense in telling people "you _should_ have
noticed" when we could improve the chances of people noticing.

> TeXinfo source? Well, probably my fault, because I got it from CVS.
> 4) Let's start with wininstall.texi. MSYS or CygWin is needed? O.k. I
>    have Cygwin installed. Let's use that. XEmacs, MikTeX and Perl are
>    installed, so all prerequisites are fine.
> 5) Error:
> ---------------------------------------------------------------------------
> makeinfo preview-latex.texi
> ' in @synindex.exi:11: Unknown index `vr' and/or `cp
> ' in @synindex.exi:12: Unknown index `ky' and/or `cp
> ' in @synindex.exi:13: Unknown index `fn' and/or `cp
> /cygdrive/c/Documents and Settings/mforster/My
> Documents/Scratch/auctex/preview/
> doc//preview-dtxdoc.texi:474: Misplaced {.
> /cygdrive/c/Documents and Settings/mforster/My
> Documents/Scratch/auctex/preview/
> doc//preview-dtxdoc.texi:474: Misplaced }.
> /cygdrive/c/Documents and Settings/mforster/My
> Documents/Scratch/auctex/preview/
> doc//preview-dtxdoc.texi:475: Misplaced {.
> /cygdrive/c/Documents and Settings/mforster/My
> Documents/Scratch/auctex/preview/
> doc//preview-dtxdoc.texi:475: Misplaced }.
> /cygdrive/c/Documents and Settings/mforster/My
> Documents/Scratch/auctex/preview/
>   style file' (perhaps incorrect sectioning?).to nonexistent node `The LaTeX
> makeinfo: Removing output file `/cygdrive/c/Documents and
> Settings/mforster/My D
> ocuments/Scratch/auctex/preview/doc/' due to errors;
> use --force to preserve.
> make: [] Error 1 (ignored)

Rats.  The problem is that the "configure" script will check for
outdated makeinfo, and will after testing install some fallback macros
to get from there.  But can't do those checks, so it
requires a recent makeinfo.  I don't see an easy way around that if
you start from CVS.

What date is your cygwin?

> Hm. seems to be just the documentation. I don't need that now. Maybe
> it's just a bug that will be fixed in some days. Ignore that:
>      touch preview/doc/
>      ./
> Now it works. Ah! Now there's also the file. Fine! But
> the line breaks are screwed up:
> ---------------------------------------------------------------------------
>    1. If you unpacked the distribution using Winzip or similar, you
>       better
>   restart using infozip on the `.zip' file, or standard
>       Unix tools
>   (see the next point) on the `.tar.gz' file: tools
>       that make the
>   mistake of turning Unix line endings into MSDOS
>       line endings will cause
>   trouble later in installation and
>       operation.

Wow.  WHAT version is your makeinfo?  This seems really ancient.  Or
could it be a line end character artifact?

> Hm, I'll stay with wininstall.texi. Seems to be the same, anyways.
> 6) Now, how do I call configure? I'll probably need --prefix? What's
>    the correct path for prefix? Probably "C:\Program
>    Files\XEmacs". wininstall.texi said to use the C: syntax with
>    forward slashes and to avoid spaces. I try to be clever here and
>    use
>      ./configure --prefix=C:/Progra~1/XEmacs
> XEmacs package directory not found. Hm. configure could have been more
> clever.

Problem is that package directories are located under the prefix, and
your package directories inside of XEmacs don't know anything about
C:/Progra~1/XEmacs.  You'd need to have specified, probably,
--prefix="C:\Program Files\XEmacs" if that is the "canonical"
representation within XEmacs.

I have to say that I am somewhat at a loss how to deal sensibly with
that: under Windows there are dozens of ways of specifying a directory
(case changes alone make for a lot of fun).

>      ./configure \
>        --prefix=C:/Progra~1/XEmacs \
>        --with-packagedir=C:/Progra~1/XEmacs/xemacs-packages
> Ghostscript not found? Did the install documentation mention that?
> Must have missed that. Well, I have Ghostscript installed. How do I
> tell this to configure? I don't want to put it in the path. Ah
> preview/ mentions it. Difficult to find. This should
> be in the top-level

Yes.  Will change that.

>      GS="C:/Progra~1/Ghostscript/gs8.50/bin/gswin32.exe" \
>      ./configure \
>        --prefix=C:/Progra~1/XEmacs \
>        --with-packagedir=C:/Progra~1/XEmacs/xemacs-packages
> ---------------------------------------------------------------------------
> checking for latex... /cygdrive/c/Progra~1/MikTeX/texmf/miktex/bin/latex
> checking for
> pdflatex... /cygdrive/c/Progra~1/MikTeX/texmf/miktex/bin/pdflatex
> checking for tex... /cygdrive/c/Progra~1/MikTeX/texmf/miktex/bin/tex
> checking for prefix from kpsepath... cat: ./conftest-3108: No such
> file or direc
> tory
> ""
> checking for TDS-compliant directory... ./configure: line 1: kpsepath:
> command n
> ot found
> no
> checking for TeX directory hierarchy... no
> checking for TeX input directory... no
> configure: error: Cannot find the texmf directory!
> Please use --with-texmf-dir=dir to specify where the preview tex files go
> configure: error: /bin/bash './configure' failed for preview
> ---------------------------------------------------------------------------
> Hm tex is found and is not found?? Again some info in
> preview/

I am in the process of folding the installation information for
preview-latex into AUCTeX, so this searching across directories for
the information will stop.  Also, the released tarball already
contains the results of running  Probably README.CVS
should be more explicitly warn from running unless you
really, really, have checked out a CVS copy.

>      GS="C:/Progra~1/Ghostscript/gs8.50/bin/gswin32.exe" \
>      ./configure \
>        --prefix=C:/Progra~1/XEmacs \
>        --with-packagedir=C:/Progra~1/XEmacs/xemacs-packages \
>        --with-texmf-dir=C:/Progra~1/MikTeX/texmf
> ---------------------------------------------------------------------------
> Congratulations!  Configuration is complete.

> Type "make" at the prompt to build preview.
> ./configure: line 3858: cd: /cygdrive/c/Documents: No such file or
> directory

Uh oh.  Have to check how this comes about.  Let me guess:  you have
something like "c:\Documents and whatever" as a directory?  How is
that related to Emacs/TeX?

> 7) Hm. Was this successfull? Let's try it:
>      make
> ---------------------------------------------------------------------------
> make[2]: /cygdrive/c/Progra\~1/MikTeX/texmf/miktex/bin/tex: Command
> not found

Let me guess: make is not from Cygwin?

> make[2]: *** [preview-mk.ins] Error 127
> make[2]: Leaving directory `/cygdrive/c/Documents and
> Settings/mforster/My Docum

Answering the "Documents and whatever" question above...

> ents/Scratch/auctex/preview/latex'
> make[1]: *** [texmf] Error 2
> make[1]: Leaving directory `/cygdrive/c/Documents and
> Settings/mforster/My Docum
> ents/Scratch/auctex/preview'
> make: *** [all] Error 2

> Hm. It doesn't seem to like my ~1 notation... Let's try it differently
>      GS="C:/Program Files/Ghostscript/gs8.50/bin/gswin32.exe" \
>      ./configure \
>        --prefix=C:/Program\ Files/XEmacs \
>        --with-packagedir=C:/Program\ Files/XEmacs/xemacs-packages \
>        --with-texmf-dir=C:/Program\ Files/MikTeX/texmf
>      make
> Same error! What? From where does configure put up the ~1??? Ah! My
> Path.

Uh, you have ~something in your PATH?

> I didn't want to spend more time and just executed the tex calls by
> hand.

Uh oh.

>      cd preview/latex
>      tex '\nonstopmode \input bootstrap.ins'
>      tex '\nonstopmode \input preview-mk.ins'
>      latex '\nonstopmode \input preview.drv'
>      pdflatex '\nonstopmode
>      \AtBeginDocument{\OnlyDescription}\input{preview.drv}'
>      cd ../..
>      make
> Ah! It worked!

As long as you are in a Bourne shell... would complain
about the quoting style.

> 8)  make install
> ---------------------------------------------------------------------------
> /usr/bin/install: omitting directory `C:/Program'
> ---------------------------------------------------------------------------

Looks like a quoting problem.  I have to crosscheck.

> grmpf!!
>      GS="C:/Program Files/Ghostscript/gs8.50/bin/gswin32.exe" \
>      ./configure \
>        --prefix=C:/Progra~1/XEmacs \
>        --with-packagedir=C:/Progra~1/XEmacs/xemacs-packages \
>        --with-texmf-dir=C:/Program\ Files/MikTeX/texmf
>      make
>      make install
> Finally!!!
> 9) Let's Start XEmacs. Auctex is started automatically on a LaTeX
>    file. Good! But it tries to execute xdvi for preview. I expected
>    that. Put (require 'tex-mik) in my init.el. Works fine.
> 10) Try preview: C-c C-p C-d, Cache preamble: y, "No such file or
>     directory gs". Customize the GS command.

What is the content of your preview-latex.el?

> Works now
> Summary of things, I'd like to see fixed:
> a) Handling of spaces in path names is subomptimal. Yes, I know, the
> INSTALL file says: Don't use spaces. Unfortunately "C:\Program Files"
> is the standard on Windows. Like it or not, but I won't install any
> software in non-standard places. If a software does not work with
> "C:\Program Files" I at least expect "C:\Progra~1" to work. If this is
> not the case, I won't use the software.

C:\Program Files _is_ supposed to work if you quote it correctly.  I
have to think about the ~1 thing: making _that_ work might actually be

> b) Fix compile error in preview-latex.texi

Does it occur only with  Namely, if you, say, delete and then just use "cd preview/doc;make" does it work then?  If it does, this is a CVS-only

> c) Fix screwed line breaks in will be included in the release, so makeinfo will not
need to regenerate it.  Nevertheless, we would want to have this work
right _IF_ people use a recent version of makeinfo.  What is the
output of

makeinfo --version

> c) Move all relevant install information to the top-level

I am already in the process of doing that.  Integrating preview-latex
is just a recent feat, and we still need to get a grip about what kind
of stuff really needs to get blended better than currently.

Many thanks for your feedback!  We are trying our best to get this to
work as well as possible, but without actual testers, there are
obviously a lot of oversights, or things where we just don't manage to
think like the users.

David Kastrup, Kriemhildstr. 15, 44793 Bochum

reply via email to

[Prev in Thread] Current Thread [Next in Thread]